Skip to main content

I finally got my CB Performance fuel Tee!

I installed the Tee, threaded/barb adapters, EFI hose and clamps to the tank. Dropped the tank in and hooked to the pre-filter and return line.

Turned the key on and got pressure. No leaks at the front. No leaks at the fuel rails, injectors, or braided hoses.

I had a small drip on the feed side though. It was where the hard line adapts to AN-6 at the engine firewall, right after the center tunnel. I took it apart, cleaned and dried, then reassembled with some fresh Permatex.

All good now! I need to get a couple gallons of fresh Ultra 93 and can try to start it up tomorrow. My friend Lenny is coming tomorrow and I'll appreciate the help.20210305_14422920210305_16273420210305_181410

I'll be sure to take some video and put it on YouTube.

Attachments

Images (3)
  • 20210305_144229
  • 20210305_162734
  • 20210305_181410
Last edited by DannyP

Super-Sano look there, Dr. P.

Hot Rod Jimmy, in my town, was helping his son do an engine rebuild on his Porsche 996 and they were both working on it over a few months.  When it came time to fire it up, Jimmy’s son wasn’t there.  Jim hits the key, it springs to life, he gets out and looks in the engine bay and it is engulfed in 🔥

He kills it, gets a fire extinguisher and puts it out with very little damage, then discovers that one of them didn’t tighten the connection at a “T” and at EFI fuel pressure it was really pumping fuel out.  There was probably enough blame for both, but they just took it in stride and the car was saved, anyway but the morale of the story is; Be like Dr. P, not like Hot Rod Jimmy.  Energize just the pump and check for leaks before you start it up!

🔥 happens.

Most of the time it’s contained.

You and Lenny gonna crack a bottle of champagne (or other sudsy adult beverage) over the nose when it cranks up?  Come to think of it it might be better to skip the "crack it over the nose" part and just enjoy the contents.  Tell Lenny I said "Hi!"

I'm saving a bottle of something to crack on a blue nose out in the midwest. After I flog the crap out of it! It's only a day's drive away...

IT RUNS!!!

It took a little to get it to fire, the injectors weren't firing at first. I think it took a little time to bleed the air out. There was fuel in the rails and to the injectors, but how do you bleed it out other than to fire the injectors, right? Then the pulsewidth for the injectors was WAY too low, not nearly enough fuel. Once we got that sorted it fired right up and ran at 800 rpm. Changed the air and fuel(more of both) and it settled into a 900-1000rpm idle.

I'll take video when I can get a chance. Lenny and I were very busy programming and tweaking just to get it to smoothly idle and accelerate. It wouldn't accelerate at all, the AE(acceleration enrichment) had to be adjusted. Boy does it jump off idle with absolutely NO bog though! Bye bye carburetors...

It's going to be in the mid 60s in the middle of next week. YEAH!

It's learning a brand new language for me. It's gonna take some time.

I did some reading and video watching last night on tuning and maps and such.

First off, at the very beginning when you punch in the engine constants, you need to get that right. After you type them in, THEN you do a fuel calculation to get a basic VE table(volumetric efficiency or required fuel).

With ITBs(individual throttle bodies) the setup is different from most cars. Port  injection sprays the fuel into the intake port on the back side of the valve, and is pretty efficient(but not quite as good as direct injection). If you check the box for throttle body, the program assumes it is a SINGLE throttle body, just like the original GM throttle body injection. Simply replace the carb with one throttle body.

https://help.summitracing.com/...ection-style-mean%3F

We don't have the injectors firing on the backside of the valve and we don't have one big spray for a V8. We have individual throttle bodies and injectors and individual intake tracts, somewhere in between the two choices in Speeduino. The difference in the fueling is almost 10% more for throttle bodies, and is about what I added to my original map to make it idle smoothly.

I've started back from scratch with this revelation.

Critical things: Crank trigger angle, falling edge/rising edge trigger, going high or going low to fire coil(and not release smoke!), fuel table.

Another biggie: TURN THE AFR compensation OFF! You need to know what the AFR is, but you want to manually control it. This is super important, you don't need the ECU trying to undo or modify the change you are trying to implement, you'll end up chasing your tail.

The other thing I noticed was how fast the head temp increases when the mixture is too lean. I richened it up and the temp came down IMMEDIATELY. I think our engines are fuel-cooled as much as air-cooled LOL!

There is a youtube guy who makes videos. All his car builds are Speeduino-based(and left hand drive). I think he lives in a British Empire island nation somewhere but haven't looked it up yet. His name is Dwayne and his channel is DC Werks. Very knowledgeable and down to earth, only a touch difficult to understand with his slight islander accent. I'm really learning a bunch from him, he has great tutorials.

https://www.youtube.com/watch?v=pwCq9t_DLr0

More to come later.

Last edited by DannyP

"The other thing I noticed was how fast the head temp increases when the mixture is too lean. I richened it up and the temp came down IMMEDIATELY. I think our engines are fuel-cooled as much as aircooled"

Sounds just like an airplane!

With Subies if you modify the air intake, and you do not check your engine ECU program,  you could lean out the mixture so much as to heat up the combustion chamber and blow the engine.   Something that I learned from my subie tech who builds race cars.

@DannyP I think that you should go visit “Dwayne” for an in-person training session of, oh, say....  A week or two.  It will be infinitely better than Youtube videos, simply because in your off hours you could be sitting on a beach in 80° weather drinking Rum Swizzles!  The Rum is really good down there, too.  We stopped there and at Martinique on a cruise years back.  Both islands are gorgeous.  You might even decide to stay!

Yeah, ship the car to St. Lucia. You'll give me the money for shipping both ways, right, Gordon?

As I mentioned on Joe Fortino's post, it was 57 today. Garage and side door open wide!

I installed some nutserts in the front trunk so I could bolt the tank in MUCH easier. It used to be a "fun" time with the wife getting those four bolts in. Got the tank install checked off the list, and re-installed the aluminum under-pan in the front.

Then moved on to more tuning. I got the start/warmup a little better and have the warm idle nailed, AFR sits at 14.1 to 14.3, cylinder head sensor is at 180F. Where the sensor is located gives about 50F LESS than the center by the plug, so idling my heads are at 230F and STAY there, no temperature creep at all.

I started playing with injector voltage correction, the fuel sprayed varies quite a bit with battery voltage. Each injector has a curve, but I didn't get a spec. sheet from CB. So you have to wing it. Mostly my voltage stays at 13.5 to 13.8, but this curve is for when your regulator dies, or your gas heater AND lights are on, which drops the voltage down to 12 or 12.5.

I started playing with the VE(volumetric efficiency or fuel load) table, changing cells and revving the motor slowly(no acceleration enrichment is programmed yet). Anyway, getting there, slowly.

I worked on the injection more today. I took a 10 mile drive after it was warmed up. I turned on Autotune and initially set it to easy(cell change resistance). Once I get it closer I'll change the setting to normal.

It seems to have MORE power than with carbs, especially down low around 2000 rpm and up. And it's smoother. I'm using MAP(manifold air pressure, or vacuum since I have no boost) for load sensing right now. At idle I have 48 kpa(kilopascals) which is about 14 and change inches of Mercury. Not what a stock motor has, since my cam is lumpy and lots of overlap, but more than enough to use for load sensing.

The cylinder head has stayed the same temp as the other day, right around 180. After I came home and shut the motor off, the intake air temp went up to over 200 F, which is an example of heat soak. It cooled right off when I restarted it. Cooling fan came on a couple times, the engine seems to warm up quicker when the AFR isn't bloody rich!

It was 55 today and sunny, no wind. It was a beautiful day to be out and about with EFI!

Iron Maiden. The shop had some Wo-Tang type designed stuff done, so I had to go the other way and had some T-shirts made with the shop name done in the Maiden letter style. They're just for the employees.

Syc maiden 2

Danny, PM me your sketch and I'll see if I can clean it up and turn it into a computer graphic so you can send it off for cards, T-shirts, magazine ads, and bill boards.

Attachments

Images (1)
  • Syc maiden 2

I haven't updated this in a while.

I've had several nice 60-65 degree days(Sunday through today) after we had a short cold spell. I've been tweaking and tuning and today I did some WOT(wide open throttle) testing. I've got it right around 12 to 12.5:1 and BOY DOES IT RUN! 90 comes up QUICK! Must be the absolutely no restriction of the 48mm throttle plates. And there is no pinging at all, even running a bit leaner than with carbs. I copied my spark curve from Megajolt(converted the 10 x 10 table to 16 x 16).

I've still got some warm up work and stepper idle speed adjustments to do. And I've started playing with acceleration enrichment today. Still the AFR control is turned OFF, I've got to get it close first before that control gets engaged.

I'm strongly considering a couple local dyno places, one in particular as they have experience with Megasquirt and it's control program Tunerstudio. It isn't hilly enough close by my house to really load the engine going up hills for long periods. I live right near a river, curvy roads but flat. I could go to some hills, but I need to drive a half-hour to do it and then there would still be traffic and pedestrians to worry about.

I'm thinking a safer and quicker solution is a chassis dyno.

It's been bright and sunny out, but there are no leaves at all, not even buds yet. Makes finding some shade so I can tweak the tune and see the laptop a bit difficult...

Last edited by DannyP

Add Reply

Post Content
×
×
×
×
Link copied to your clipboard.
×
×