Skip to main content

I let my Beck Speedster sit for a tad too long without driving it or putting Stabil in the tank. It's a 2009 build with EJ25 Subaru engine built by Outfront Motorsports in conjunction with Beck. I started noticing engine hesitation when going uphill.  This started a long diagnosis process which has led me to now replacing my fuel pump.

The flow of fuel in the system is...

  1. Gas tank 1/2" barb out
  2. Short 1/2" ID hose with clamp
  3. 1/2" barb inlet on 147 micron fuel filter (https://www.napaonline.com/en/p/FIL3248) to 1/2" barb outlet
  4. Short 1/2" ID hose with clamp
  5. 1/2" barb inlet on Pierburg 7.21659.02 to 10mm x 1.0 threaded female out
  6. 10mm x 1.0 male threaded to 6AN flare fitting (blue aluminum in attached photo)
  7. 6AN swivel 90 to 3/8" barb fitting (blue/red aluminum in attached photo)
  8. Short 3/8" ID hose with clamp (bent hose in attached photo)
  9. 3/8" barb inlet on 20 micron fuel filter (https://www.napaonline.com/en/p/FIL3033) to 3/8" barb outlet
  10. Long 3/8" ID hose that runs to rear engine about 7’...


I'd like to replace my fuel filters with 100u and then a 10u post fuel pump.
I spoke with John Rykowski, owner of Outfront Motorsports, who mentioned he has a 1/2" barbed 100u filter and a 10u post fuel pump one, but it's a 5/16" or 8mm and NOT 3/8". Furthermore he claimed that "there is no 3/8 fuel injected filter that i know of   and your motor does not have 3/8 line either". He made it sound as if it's unsafe for me to go this route stating "that is not the right way nor safe--you make the call".

My question to you all is how can this be unsafe? This is how my car came from Beck. I've driven it for 6+ years without issue. The fuel line after the post fuel pump filter is 3/8" ID SAE30R6. It runs about 7' in the transmission tunnel before it gets to the engine. All of the fuel filters are connected with hose clamps.

I have a new Pierburg 7.21659.02 arriving shortly. I just need to know what filters I should use. What do you guys think?

I've attached a few photos for reference. Thank you in advance for any advise.

Attachments

Images (7)
  • 01 - Gas Tank Pre Filter
  • 02 - Pierburg
  • 03 - Pierburg and AN fittings
  • 04 - Post Filter Fuel Hose
  • 05 - Fuel Line
  • 06 - EJ25 Top View
  • Pierburg Fittings
Original Post

Replies sorted oldest to newest

Having just gone down the EFI route, I have something to say here.

Subaru uses 5/16" or 8mm throughout. According to Jegs or Summit that size line supports up to 400 hp.

Anyway, the pre-pump fuel filter I used is a standard NAPA 3/8" in and out. So I used 3/8" line there, and my MSD pump is 3/8" in and 5/16" out. I used 3/8" BECAUSE the pump inlet is 3/8". At the out of the pump I used 5/16". I used a standard Subaru filter, the round one that they usually install in the engine compartment just before the fuel rail.

In the engine compartment I used AN-6, in the tunnel I used 5/16" Nickel-copper solid lines.

Check out my thread in Spyders/EFI conversion of my Spyder.

You have, essentially, the same fuel pump/filter rig as I have in my home-built TD. The pump is SAE for a late 1980s Ford F-150 truck. Good stuff.

As for the fuel lines.... Change them now. 11 years was a good run.

I like hard steel lines after the pump and before the engine. I pulled out and used some from the Legacy wagon I dismantled to get the engine and electronics, flaring the ends myself. But fuel injection rated rubber hose will work just as well. Plug the new line into the end of the old one and pull it through the tunnel.

The important thing to remember is that your high pressure system is basically only between the business end of the fuel pump and the pressure regulator on the engine intake manifold. All the other lines—tank to pump, return line—are low pressure.

I mean...use FI hose there too (I did!) but it's not strictly needed.

On those rubber, FI rated lines use FI-rated clamps. NOT worm gear clamps.

As for your high-pressure filter? I just repurposed the Subaru item. It's a bulky canister like thing and it works perfectly and it's not expensive.

Oh, and also:

USE THE DIAMETER FUEL LINES THAT FIT THESE COMPONENTS.

Just push the line onto the nipple. If it fits, use it. Too tight or loose? Choose another size.

Finally: AN stuff is awesome but there's no point in making a system with barbed and AN fittings. Barbed fittings with good clamps will serve you perfectly well in this system.

Last edited by edsnova

Thanks for all the info @edsnova and @DannyP!

To be safe I've ordered all new Gate Barricade Fuel Injection hose between the tank, first filter, pump and last filter even though the pre pump stuff isn't high pressure.

I hadn't realized there were special FI-rated clamps and not to use worm gear clamps. Thank you for the tip!

What's the in/out barb fitting size on the repurposed the Subaru filter? What's the micron filtering on it?

I know the Pierburg pump outputs 95psi, but I was hoping NOT to replace the 3/8" line after the 10u post pump filter, b/c it seems like a major pain accessing it through the transmission tunnel. Do you have any pics of your work there @edsnova?  You really think 11 years of mild use is worthy of replacing all those lines?

Last edited by Nick
@Nick posted:


I hadn't realized there were special FI-rated clamps and not to use worm gear clamps. Thank you for the tip!

What's the in/out barb fitting size on the repurposed the Subaru filter? What's the micron filtering on it?

I know the Pierburg pump outputs 95psi, but I was hoping NOT to replace the 3/8" line after the 10u post pump filter, b/c it seems like a major pain accessing it through the transmission tunnel. Do you have any pics of your work there @edsnova?  You really think 11 years of mild use is worthy of replacing all those lines?

Yes there are. Worm-drive clamps are an issue for me: they loosen AND destroy the hose when overtightened. Amazon sells these in whatever hose size you need, these are 8mm or 5/16":  https://www.amazon.com/XtremeA...Clamps/dp/B0040CU0HM

The Subaru filter is 8mm which is EXACTLY the same size as 5/16". I don't know the micron rating and didn't bother to look it up for either of my filters. The standard metal can NAPA pre-filter as I said is 3/8". I figured it is a REALLY good idea to pre-filter before the pump. If the Subaru filter is good enough for a 300hp STi, it's good enough for me.

I wouldn't run rubber hose THROUGH a chassis, none of the OE manufacturers do that. Everyone runs solid steel lines. The key thing is to protect them where they go through bulkheads with grommets and/or sleeving of some sort. One year or eleven doesn't matter to me, if I can't see the line to inspect it, it has to be a solid metal line.

@edsnova what is your issue with AN hoses partway? I have black braided nylon AN for my oil cooler and also for my breather setup. I merely continued the theme. You're right that it isn't necessary but to me it looks right, like they belong there. They really weren't much of an expense.

And I also agree with Ed to use the correct hose for the barb fitting. A 5/16" Gates EFI Barricade hose will go onto a 3/8" barb, but man it's a bitch. I had thought I was using 3/8" hose on 3/8" fittings, but realized it was 5/16" after a LOT of wasted effort. DUH! Using the correct size is a lot less effort, sore fingers and swearing.

Last edited by DannyP

Wow this is one of the very very early Subaru builds.  We didn't use Outfront Motors for very long.  Great motors, but we quickly changed to stock ECUs and USDM motors to simplify the parts catalog.  There are a TON of updates to the Suby builds, fuel system and coolant system, but I am also a fan of "if it ain't broke"...

There are plenty of inline fuel filters and pre-screeners in 3/8", 5/16", 1/2", that are rated for fuel injection systems, check Speedway motors or various aftermarket diesel products, its common.

Your clamped fittings are all high pressure socketless and the clamp is a back-up, nothing wrong with them but also nothing wrong with updating them, just not necessary.

Surprised about the Outfront comment on sizing, as that would be the pump and fittings they supplied with the motor at the time.  Likewise, I don't understand why someone would run a step up fitting to try and force larger diameter line when the fitting size is already a restriction and dictates the size...

The cars today (and for the last 10 years maybe) have 3/8" feed and return throughout, matching the donor components.  The outfront stuff back then used a JDM top end and from memory is set up for 3/8 and 5/16 mix (or metric equivalent).

As for fuel line and age, we haven't seen long term aging issue with Gates Barricade hose, which is our standard, but I DO NOT know if we started using it back in '09  Best to do a physical inspection on your fuel lines.  The ethanol content of today's fuel will dry out standard rubber hose quicker than expected.

@Nick posted:

Thanks for all the info @edsnova and @DannyP!

To be safe I've ordered all new Gate Barricade Fuel Injection hose between the tank, first filter, pump and last filter even though the pre pump stuff isn't high pressure.

Do you have any pics of your work there @edsnova?  You really think 11 years of mild use is worthy of replacing all those lines?

I ran my hard lines alongside the tunnel. It's invisible under the carpet. Converted the original fuel line into the vent line to the charcoal filter.

Like Danny says, grommets:

Your Beck may have an access door (or doors) into the tunnel from underneath. If you put the car in the air you should be able to see, and if you have them you can inspect and change everything out more easily.

Honestly the hose is probably fine, but...while you're in there.

And yeah it's a PITA. My neighbor just finished putting his fuel and return lines in the tunnel of his Ghia. Pan is bare and he has 360-degree access but still took a few hours. He used hard lines, of course.

Finally, I must have been mistaken re your pump as compared to mine. Yours makes 98 PSI?? The pump in mine (I measured) generates about 38 PSI at the head with the engine off (it can go to like 45-50 when the regulator squeezes it). It's a stock 1995 EJ22 and it seems to like that just fine.

At 98 lbs pressure I'd be even more fastidious about fuel line maintenance.

It's useful to remember that the Subaru factory engineers got about 95 percent of what was to be gotten out of these engines, in NA trim—and it's more than plenty for a clown car. With the possible exception of head gaskets, it simply doesn't pay dividends to deviate from their formula.

@edsnova When looking at the Pierburg spec sheet, it appears to say 6.5bar and 94psi for the 7.21659.72 model, but maybe that's max PSI? I also have a Walbro GSL392 pump that I could use. It has a "typical" PSI of 43.5 and "max" of 87PSI. The flow rate between those is the huge diff. The Walbro is 255LPH, while the Pierburg is 110LPH. I was planning on putting back what was already in there to begin with just to keep it simple/consistent and also avoid potentially having to reprogram the EMS Stinger 4424 ECU. Any advice/suggestions here as to which pump yall would use would be appreciated!

@chines1 I was hoping you'd chime in! Yeah, I found a 10u EFI rated post pump filter, but it has -6AN fittings and max PSI rating of 60PSI. I wonder if that Pierburg pump really outputs 94PSI. That seems insane and would make pairing it with a 10u filter all the more difficult.

@chines1 can you explain or point out what you mean with photos by "Your clamped fittings are all high pressure socketless and the clamp is a back-up, nothing wrong with them"? All the fittings between filters and pump appear to be barbed and using those worm screw clamps.

I was equally confused/bummed with John Rykowski said that's not their work, he could spot his work from a mile a way. Then proceeded to mention all the unsafe aspects of the setup. When I explained that it's been running fine for over 7 years he really didn't have anything to say. Anyway, I'm just trying to find the best way forward at this point.

I realize there's an ideal way to do things which is likely to redo the hosing between the engine and pump, but that's a project I'll have to put off a tad longer as it doesn't seem trivial by @edsnova photos/explanation (thank you for that BTW). I definitely want to do that sometime fairly soon, but probably not immediately.

For now I am just trying to get the engine back to running as it was before the bad gas screwed things up. To do that I think I simply need to...

  1. Replace 1/2" barbed 100u tank fuel filter
  2. Replace the fuel pump (need to figure out whether to use Walbro GSL392 or Pierburg 7.21659.72)
  3. Replace 3/8" barbed 10u post pump filter with something EFI rated
  4. Use any fittings to convert the post pump filter to work with 3/8" hose
  5. Replace all short hoses, except the one in the transmission tunnel, with Gates Barricade Fuel Injection
  6. Use proper SS hose clamps vs worm clamps?


Thoughts?

For 180 hp you need less than 15 gallons per hour, or less than 60 liters. Either pump is fine and is MORE than adequate for your needs.

Most injectors are rated at 43.5 psi which is the usual pressure regulator setting. The gallons per hour of the pump doesn't matter as long as the motor's needs are met.

@Nick Have you put a pressure gauge on the setup as-is to determine the fuel pressure and flow? Are your injectors clogged? Do you plan to have them cleaned or replace them?

If the injectors are clogged you can change every other part and it won't run.

If it were me, I'd drain the tank and clean it, put new filters in and run the pump to flush the lines. Then I'd clean the tank again and replace the filters and call it a day(but that's assuming you have fuel flowing and pressure).

@DannyP great advice. 

I already drained the tank and replaced the filters once, but didn't replace the pump and that didn't fix the hesitating engine.

My current plan is to repeat that entire process, but this time replace the filters and pump and more thoroughly clean the tank then see if my problem is solved. If not, I will proceed to cleaning the injectors and checking pressure.

Any tips on cleaning the tank thoroughly?

FWIW, the Pierburg pump has a screen on the inlet side. I removed that and some dusty crumbs fell out. I definitely think the root cause of this is me letting the car sit for too long and the gas separated. I'm just praying the gummy crap didn't make it past all the filters into the injectors.

I have from the tank, a pre fuel filter,

NAPA Gold 3299

then the walbro pump, rubber hose (not sure what type) then solid line all the way to the rear engine area where it goes again to a flexible line  In engine compartment: Bosch 71028 filter.  SS clamps here as well.  

Danny is right, clean the tank, change the filters, run the pump check the pressure and there should be no need to change everything unless you find a leak.  

Well I can't help you on that one, someone here surely can, but I would think that if you have done all the cleaning disconnecting the tube at the engine end and having someone turn the key would have the pump give you fuel that you could collect to see how well the pump is doing.   I mean if you get a half gallon in a short period you can see how productive the pump is.  After that I would try maybe some injector cleaning fluid in the gas.  I have no clue on cleaning the existing injectors  @DannyP

You can send the injectors to be cleaned, or just replace them like for like. I think they are $40 or less depending on what they are and where you get them. There should be numbers on them but I'm thinking they are the stock Subaru OE injectors.

The best way to clean the tank is with shaking/vibration and ball bearings inside. Not really an option considering the size, but this works well for motorcycle tanks.

A chemical clean followed by a good gas tank coating is the usual procedure though.

To get a pressure reading get a metal T, good EFI hose clamps and a high-enough pressure gauge, put it inline before the regulator so you'll know your rail pressure.

For volume you can bypass the fuel pump shutoff and run the pump for X(15 or 30) number of seconds. Collect gasoline in a bucket AFTER the regulator and do the math to get liters per hour or whatever unit of measure is your pleasure. Don't forget to plug the return line or you'll have a mess!

re: fuel pump suggestions, we use Walrbro GSL392 with an external regulator, set to match donor engine specs.  Most of the EJ25 NA motors are around 50psi.  Outfront will likely have completely different specs.

I seem to recall Outfront motors using a non-Subaru Bosch injector, but I may be mistaking here on the crossover to Subaru.  They could be an OEM equivalent.  I definitely remember them using a custom aluminum fuel rail with inlet/outlet plugs and having to clean them out.

@Nick posted:

@chines1 I was hoping you'd chime in! Yeah, I found a 10u EFI rated post pump filter, but it has -6AN fittings and max PSI rating of 60PSI. I wonder if that Pierburg pump really outputs 94PSI. That seems insane and would make pairing it with a 10u filter all the more difficult.

@chines1 can you explain or point out what you mean with photos by "Your clamped fittings are all high pressure socketless and the clamp is a back-up, nothing wrong with them"? All the fittings between filters and pump appear to be barbed and using those worm screw clamps.

Was just saying that the AN fitting on the pressure side of the pump is a socketless (made as a push on not requiring a hose clamp, however I am not comfortable with that so we add a clamp... fail safe.  Yours cad a clamp and although not high tension it should be fine.   Your clamps before the pump, off the tank and at the pre-filter, are all on the gravity fed side and also adequate as they are not under pressure.

Add Reply

Post Content
×
×
×
×
Link copied to your clipboard.
×
×